WordPress 3.4 Beta 1

WordPress 3.4 Beta 1 has been released! The final version is expected to ship sometime next month (May 2012).

What’s New

  • Theme Customizer with Previewer
  • Flexible Custom Header Sizes
  • Selecting Custom Header and Background Images from Media Library
  • Better experience searching for and choosing a theme

Under-the-hood Changes

  • New XML-RPC API for external and mobile applications
  • New API for registering theme support for custom headers and backgrounds
  • Performance improvements to WP_Query by splitting the query (Please test!)
  • Internationalization improvements (improved performance and locale support)
  • Performance and API improvements when working with lists of installed themes
  • Support for installing child themes from the WordPress Themes Directory

Download: WordPress 3.4 Beta 1

4 thoughts on “WordPress 3.4 Beta 1

  1. Meg

    Hi Lester — I have a question regarding a plug in, and I know this isn’t the right place to ask, but I’m unable to register on your forum and so I cannot ask there, and I wasn’t sure of your email so I thought this would be the next best place.

    Your WP-Email plug-in is awesome and exactly what I need, but I noticed it has stopped working. I have installed it exactly as you directed and for a while it worked, but now that I’ve updated to the latest version of wordpress (not sure if this is my problem) every time someone sends an email they get an error message: “Message body empty.” Even when you type a message in the message box you still get the error. Is there something that can fix that or does the plug in not work with newer versions of wordpress? I have never checked my email logs until this week and noticed that emails were successful until July of 2011. That’s when every email failed. I know you’re busy, but if there were a way to fix this I would be so grateful.

  2. Meg

    Also, when I try to email your posts to myself, I never get an error, but I also never get the email. It says it was successful but I never receive it.

  3. Meg

    I just tried it on the Twenty Eleven theme and it worked perfectly, so I guess I must have screwed things up during a theme update. I know nothing about javascript, so I have no idea how to fix it or if there is even a fix for it. Any idea on where to go or what file the problem might be in? What I should look for?

Comments are closed.