Plugins Compatible With WP 2.3

I have updated this site to WordPress 2.3 Beta 1 as well as ALL my plugins to be compatible with WordPress 2.3. All the plugins are running live on this site. If you find any bugs, kindly do let me know by posting it in the forum.

I will be releasing the updated plugins (except WP-WAP and WP-ServerInfo) after WordPress 2.3 is officially released.

After doing some reviewing, most of my plugins will be able to work on WP 2.1 and above (including WP 2.3) except for WP-Stats 2.20 where you need to have at least WP 2.3.

All the plugins version listed below is the upcoming version and NOT the current version (except for WP-Stats 2.11).

Plugins that will work for 2.1.x and above (including WP 2.3)

  • WP-Ban 1.20
  • WP-DBManager 2.20
  • WP-PageNavi 2.20
  • WP-PluginsUsed 1.00
  • WP-RelativeDate 1.20
  • WP-ServerInfo 1.00
  • WP-WP-WAP 2.10

Plugins that will work for 2.1.x and above (including WP 2.3) 1 BUT will break WP-Stats 2.11

  • WP-DownloadManager 1.00
  • WP-Polls 2.21
  • WP-PostRatings 1.20
  • WP-PostViews 1.20
  • WP-Sticky 1.10
  • WP-Useronline 2.20

1 As the whole structure of WP-Stats had changed, any plugin version prior to the individual version stated above will break WP-Stats 2.11. The only solution to this, is to upgrade WordPress to 2.3, WP-Stats to 2.20 and the respective plugins to the version stated above. If you are not using WP-Stats, you can just ignore this.

Plugins that will work for 2.3 Only

  • WP-EMail 2.20
  • WP-Print 2.20
  • WP-Stats 2.20
1 Star2 Stars3 Stars4 Stars5 Stars (19 votes, average: 3.95 out of 5)

WordPress 2.3 Beta 1

WordPress 2.3 Beta 1 will be release later. Note that IT WILL NOT WORK with the current version of ALL my plugins as the whole /wp-admin/ folder had underwent some restructuring.

There WILL NOT be any more categories, link2cat, or post2cat tables. It will be replaced by terms, term_taxonomy and term_relationships. It means that my plugins MAY break as some of the functions uses direct query to those depreciated tables.

I will update the current development version of ALL my plugins to be compatible with WordPress 2.3 and above. If you are using the development version of my plugins for WordPress 2.2 after I updated all of them, it WILL BREAK.

I will post another entry once I have completed updating all of them to be compatible to WordPress 2.3.

1 Star2 Stars3 Stars4 Stars5 Stars (13 votes, average: 3.92 out of 5)