Lester Chan’s WordPress Plugins December 2008 Update

Here is my December 2008 WordPress plugins update containing all my 15 WordPress plugins update and 1 new WordPress plugin. All of them should work on WordPress 2.7 as I did not test them on any WordPress version below that.

I am introducing a new plugin called WP-CommentNavi which basically paginate your comments similar to how WP-PageNavi paginate your posts. I am also retiring WP-Sticky as WordPress 2.7 has a sticky post feature built in. WP-Sticky 2.31 WILL NOT work on WordPress 2.7 due to a conflict function “is_sticky”. If you renamed that function to “is_sticky2″ or something else, it should work, but as usual I did not test it.

*UPDATE* Due to the large number of requests, I decided not to retire WP-Sticky and I have updated it to 1.40 and it is now compatible with WordPress 2.7.

Be sure to read the readme.html and checkout the changelog for more information and most importantly NOTE THE TABS AT THE TOP

WP-Ban 1.40
» Readme/Changelog
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-CommentNavi 1.00
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-DBManager 2.40
» Readme/Changelog
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-DownloadManager 1.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-EMail 2.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-PageNavi 2.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-PluginsUsed 1.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-Polls 2.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-PostRatings 1.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-PostViews 1.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-Print 2.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-RelativeDate 1.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-ServerInfo 1.40
» Readme/Changelog
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-Stats 2.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-Sticky 1.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

WP-Useronline 2.40
» Readme/Changelog
» Demo
» Download Mirror #1
» Download Mirror #2
» Support Forum

If you like or love my plugins a lot, do consider making a donation to me. My Paypal email address is lesterchan AT gmail DOT com. Thank you =D

19 thoughts on “Lester Chan’s WordPress Plugins December 2008 Update

  1. Pingback: Blog » WordPress 2.7 Will Feature Sticky Post | lesterchan.net/wordpress

  2. dave

    lester, you are AMAZING! not only are these plugins all outstanding, but your support forums are incredible (i mean your responses!!)

    out of curiosity, i was wondering if you’ll be writing up any kind of blog summary that explains what exactly happens if one uses (for example) a plugin that duplicates new 2.7 functionality – the biggest one that jumps to mind is comment paging as well as ‘wp sticky’

    would usign these plugins cause errors or in any way duplicate calls or functions? should we effectively pick one or the other!?

  3. Nehemoth

    Hello Lester.
    First thank your for your great plugin.

    I’m using WP-EMail 2.31 and WP-PostRatings 1.31 but I did not received any notification for update to 2.40 and to 1.40 respectively so what I want know if I can download the plugins, disable it in wordpress, update it and activate it again without lost any configuration or should I do a backup or has to reconfigure after the update?.

    Best regards

    Also you should use the plugin Subscribe To Comments.

  4. Bharat Karavadra

    Hi Lester.

    Thank you very much for creating v 2.40 of WP-Print & WP-Email – I upgraded to WordPress v2.7 from v2.65 and read that these two plug ins of yours required updating.

    Well I did just that and the print and email links didn;t work – I went through your forums and saw other people having a similar problem.

    The fix which is probably not a fix, but something I forgot to do, was to simply re-create the Permalinks and both plug ins work fine now.

    Thank you very much for your work to date – you are providing an invaluable service to the WordPress community.

  5. Lester Chan Post author

    @Nehemoth: There is some problem with the plugins repository, apparently it only detected updates for WP-Sticky and WP-RelativeDate even though I committed them altogether. Updating the plugin will not lose your configuration. If you asked me, I would prefer to update it manually. Just download the plugin, deactivate the previous version of the plugins and then overwrite the files and activate it back.

    @Bharat: Thanks for the compliments =)

  6. Ferdi

    Hi,

    I just want to inform you about an experience with your database plugin WP-DBManager…

    I am using WP 2.7 and I made a backup of the whole database (before manipulating some tables…)

    The manipulation failed and I started to restore the backup. But I could not manage it. Neither from within your plugin nor with phpMyAdmin…

    Eventually I found a solution: I removed all “LOCK TABLE/UNLOCK TABLE” commands of the database backup file and afterwards it worked…

    Perhaps it was due to the fact that my hoster provides MySQL 4.1…?

    Regards,

    Ferdi

  7. Thomas

    Hi Lester

    I’m using your wp-print on some pages. And I like it a lot. On one page I GET THIS INFO…

    “Restricted
    (403 – Forbidden)
    Access to this site is currently restricted. Please try again in one hour. If you own this website, please contact your web host.

    Thank you!”

    Do you know any plugins, there don’t work with your plugin? I don’t know what to do. My host are trying too.

    Thomas

  8. jopicar

    Hi Lester!

    Thanks a lot for your work, really apreciated.
    Now, i have a proble trying to register on your forums. I can´t do it because the letters on the picture were wrong. I´m sure i have typed the letters correctly but the system is not agree :)

    I need to solve a doubt with wp-downloadmanager. I woud like to show a link to the post which contain the download link. Can i do that? and how?

    Thanks again

    Best regards.

Comments are closed.