My Plugins And WordPress 2.5

The current version of all my plugins will work on WordPress 2.5 PROVIDED you have upgraded your WordPress blog from WP 2.x to WP 2.5.

If you are using a fresh copy of WordPress 2.5 together with my plugins, it WILL NOT work as WordPress 2.5 changes the Activation Global Scope Of The Plugins. In simpler terms, it means that upon activation of my plugins in WP-Admin, it will not create the tables needed by the respective plugins.

To solve this problem temporary, do the following in polls.php (I am using WP-Polls as an example):

Find:

$wpdb->pollsq = $table_prefix.'pollsq';
$wpdb->pollsa = $table_prefix.'pollsa';
$wpdb->pollsip = $table_prefix.'pollsip';

Replace:

global $wpdb;
$wpdb->pollsq = $wpdb->prefix.'pollsq';
$wpdb->pollsa = $wpdb->prefix.'pollsa';
$wpdb->pollsip = $wpdb->prefix.'pollsip';

Note the addition of the “global $wpdb;” and the replacement of “$table_prefix” with “$wpdb->prefix“.

I have updated WP-Polls, WP-ServerInfo, WP-Sticky and WP-UserOnline to work with WordPress 2.5. You can get them here at my downloads page (do note that they are still in beta). Those plugins that end with a “Beta 2” means it will work for WordPress 2.5.

Some of the updates are:

  • Making sure that the styling, alignment and color of the plugin matches WordPress 2.5
  • Fixes the “Activation Global Scope” issue
  • Updated WP-Polls TinyMCE plugin to work with TinyMCE 3.0
  • Added a summary of WP-ServerInfo as a Dashboard Widget
  • Added a summary of WP-UserOnline in the Right Now Dashboard Widget
1 Star2 Stars3 Stars4 Stars5 Stars (61 votes, average: 3.77 out of 5)